TechSmtih Relay (Hosted): Issues signing into Relay from Recorder or Camtasia

Description:

When logging into TechSmith Relay from either the Windows Recorder or Camtasia (via the Share to Relay option), the error "this page can't be displayed" is displayed in the browser and the user is not logged in.

 

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Cause:

Computers running Microsoft Windows 8.1 that have Internet Explorer 11 set as the default browser can exhibit this behavior.

 

Work around: 

Change the computer’s default browser from Internet Explorer to either Mozilla Firefox or Google Chrome or update the computer to Windows 10.

 

*If this workaround does not seem to resolve the problem, please contact support for further assistance.

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