Snagit (Windows): Capture fails, Capture is blank, or no image appears in the Editor

Problem

After taking a capture, a blank image may appear in the Editor. Or, no image will apear at all. This can be a symptom of Snagit not having the ability or permission to write to the necessary folder, the DataStore. The steps below describe how to resolve this isssue.

Solution

Windows 7/8/10

  1. Completely close out of Snagit.
  2. Confirm that Snagit has been closed by checking your task manager (Ctrl + Alt + Delete) and make sure that these three processes are not running:

    • Snagit32.exe
    • SnagitEditor.exe
    • SnagPriv.exe
      Note: You may need to select More Details in the Task Manager for Windows 8 / 10
  3. Hold down the Windows key on your keyboard, and then hit the R key to open the Run window

    Tip:

    For Windows 8 / 10 users, you can also right click on your start button and choose Run.

  4. Type the following and then hit Enter:  

    Windows Vista/7/8/10: %LocalAppData%\TechSmith\Snagit\
    Windows XP: %userprofile%\Local Settings\Application Data\TechSmith\Snagit

  5. Right click on the Datastore folder here, and copy and paste it to a safe location.
    Warning: The Datastore folder contains your old captures, so make sure to follow step 5 to create a back up if you wish to keep them. 
  6. Delete the Datastore folder in %LocalAppData%\TechSmith\Snagit\
  7. Launch Snagit again and see if it works.  Snagit will re-create a new Datastore to store new captures.

If this does resolve the issue, your old captures are in the backed up Datastore created in step 5.  These can be opened by double clicking the .SNAG files inside (this will also re-add them to your new Library). 

Was this article helpful?
15 out of 32 found this helpful