Camtasia for Windows Media Library

Camtasia Mac Information

The Library feature is not available on the Mac platform. However, the royalty free, professionally created media available in the Camtasia Windows Library is available to download and use with Camtasia Mac here:

https://www.techsmith.com/camtasia-accessories.html

To use, download and unzip a media file. Then, import the media clips into your Camtasia Mac project.

 

The Library holds timeline sequences, video, audio, and image clips you want to use from project to project. Items in the Library are called media assets.

To open the Library:

  1. Click the Media tab. 
  2. Click the Library sub-tab. 
  • The Library comes pre-populated with royalty free media assets to add a professional look to your videos.
  • To add a media asset to the video, drag the asset from the Library onto the timeline or right-click on an asset and select Add to Timeline.
  • If you have a particular sequence you want to use at the beginning or end of every video you make, create the sequence one time and save it to the Library to be used in other video projects.
  • If your company uses a standard callout, title clip, or transition for their videos, add those elements to the Library then export them and share with everyone on your team.

Media Files & Timeline Assets

The following media can be added to the Library for use in Camtasia Windows projects.

Cross Platform Compatibility Tip!

Some Library media is not compatible with Camtasia Mac. For best results when creating cross-platform projects, do not use incompatible file or media types.

Add to Library to reuse in other Windows projects.

These media files are not compatible with Camtasia Mac.

Camtasia Recording Files:

.trec, .camrec

Camtasia Recording Files:

CAMREC - Legacy Camtasia Studio recording file (Camtasia Studio version 8.3 and earlier)

Video Files:

AVI, MPG, MPEG, WMV, SWF*

Only SWF files created with Jing or a previous version of Camtasia Studio.

Video Files:

AVI, WMV, SWF

Image Files:

BMP, GIF, JPG, PNG

---

Audio Files:

WAV, MP3, WMA, M4A

WMA

LIBZIP - Zipped Library Files LIBZIP - Camtasia Zipped Library Files
Callouts Camtasia Studio Legacy Callouts

Timeline selections with or without transitions and animations

---

Groups with or without transitions and animations

---

Quizzes, Animations, Visual Effects, Audio Effects, Captions, Behaviors, and Cursor Effects in a group or on a timeline selection

---

Working with the Library

To perform this action....

Do this...

To add a media file or timeline asset to the video... Drag it from the Library onto the timeline or right-click on an asset and select Add to Timeline.
To create a Library asset... Make a media or playhead selection on timeline, right-click it and choose: Add Timeline Selection to Libraryor Add to Library
Manage Library media...
  • Click the asset in the Library to rename it.
  • Drag asset into a folder for better Library organization.
  • Drag asset to the timeline to include in the final video.

Manage Library Content

Saving Media to the Library

When a video sequence is saved in the Library, the entire video is saved. If your video is large, consider producing the timeline selection as an MP4 video file, then add that smaller clip to the Library. Keep Library assets as small as possible to improve Camtasia performance.

Moving or deleting Library assets can break other Camtasia projects using those assets. Before moving or deleting any files, open your video projects and export them as a Camtasia zipped project file. Be sure to select the Include all files from the Media Bin in zip option. This creates a self-contained project with backed up Media Bin files.

To perform this action....

Do this...

View media details like file name, location , creator, or size... Right-click on a Library asset and select Details from the context-menu.
Change an asset’s name... Click once on the asset, pause for a moment then click again. The name becomes highlighted. Type the new name.
Create a folder...

Right-click in a blank area of the Library tab. From the context menu, select New Folder then type a name for the folder.

Note: Subfolders are not supported in the Library.

Delete an asset from the Library...

Right-click the asset and select Delete from Library from the context menu. You are prompted to confirm the delete.

Note: If the asset is in use on the timeline, the asset cannot be deleted from the Library.

Delete a folder...

Right-click on it and select Delete from Library from the context menu. You are prompted to confirm the delete.

Note: If the folder contains assets in use on the timeline, the folder cannot be deleted from the Library.

Remove broken links, rebuild the Library indexes, and update folders...

Note: If you frequently add, delete, and move assets within the Library, it is good to perform this routine maintenance on a regular basis.

Go to Edit > Preferences > Advanced tab > Clean Up Library. You are prompted to confirm the process.

Copy or Link assets to Library...

When assets are added to the Library, they are added as a copy of the asset file or a link to the asset file.

To select a default method for adding assets, choose Edit > Preferences > Advanced tab > Library Content group box.

  • Copy saves a copy of assets in the Library. Since copied assets increase the file size of Camtasia projects, it is best to only copy assets used from project to project . Use the Media Bin to hold files needed just for the current project.
  • Link option links to the original asset file on a hard drive or network location. Since moving the asset from its original location breaks projects that link to those files, it is recommended that assets be placed in a location where they will not be moved or accidentally deleted.

Export & Import Zipped Library Assets

If you or your company uses a particular callout, title clip, survey, transition, etc. in your videos, create those assets one time, add them to the Library, then export the Library as a zip file (.libzip) to share with others. Those who receive a zipped library file can import that file into Camtasia using the import option. You can export a folder(s) or the entire library.

To perform this action....

Do this...

Export Assets or the Entire Library as a Zip File
  1. Click to select an asset file or a folder.
  2. To select multiple files or folders, press and hold the CTRL key and click to select each file/folder.
    • To export the entire Library, do not select any files.
  1. Right-click a selected asset(s) and select Export Selected Assets from the context menu.
  2. To export the entire Library, right-click the blank area at the bottom of the Library and select Export Library from the context menu
  3. Accept the default file location and file name or click the Browse button to choose a new location and name. Click OK.

Import Zipped Library File from Editor

  1. In Editor, select File > Library > Import Zipped Library.
  2. The Import Zipped Library dialog appears. Browse for and select a LIBZIP file. Click Open.
  3. Click OK to begin the import.
Import Zipped Library File from Windows Explorer
  1. In Windows explorer, double-click a LIBZIP file.
  2. A confirmation dialog appears. Click Yes to begin the import.

 

Did you find what you were looking for? Provide feedback.

Was this article helpful?
4 out of 8 found this helpful