Jing Needs to be Updated Error

Problem

When attempting to open Jing on Mac, Jing needs to be updated is displayed.
Jing_NeedsToBeUpdated.png

This issue occurs when the macOS is upgraded to macOS Catalina. Jing will only stop working when upgrading to macOS 10.15 Catalina. With this new release, any 32-bit applications will no longer be supported, including Jing. To continue using Jing, only upgrade to macOS 10.14.6 Mojave.

Solution

If you are running macOS Catalina Snagit 2019 is a 64-bit application and is tested and supported on macOS Catalina.

We are currently working on a free solution that will be compatible with Catalina.

You can learn more about this here.