How can I change the default file type for saving images

Completed

Comments

22 comments

  • stephensterry853
    SnagIt saves to the "Editor / Library" as a .snag by default and you cannot change that.

    However, if you save your captures to a folder as a png it will be saved as a png.I'm not sure what version of SnagIt you're  using but version 12 is shown below.

    Regards,Joe



    0
  • Mohsin.Ahmad
    How to get Share properties on snagit 11.1.0?
    0
  • stephensterry853
    0
  • Niki Estner
    Hi Joe,

    thanks for the quick reply. Now I see what I did wrong: I used the "All-in-one" capture option (SnagIt 13). For that option, I can't change the filename. I didn't know I had to create a new profile.

    Maybe in the next version, you could add a default file type for the "All-in-one" option as well.
    0
  • rgrun
    Can you not make a copy of the all in one and  change the settings as Joe described? Just rename it something that makes sense to you an add a  hot key if you wish
    0
  • cyrusmd

    This screenshot is from v11.4.1. I have been using as default file format .jpg and I can name it whatever I want

    0
  • Arthur Taylor
    Helpful
    0
  • Gsimonis

    It is possible to change the DEFAULT file saving format in Snagit!!! The instructions at the top were close, yet did not take you all the way. Follow the steps below and it works like a charm:

    1. Open the Snagit Editor and check your current Snagit "Save As" settings. If it's not saving as the file type you want, continue below.
    2. Open a file to use as a demo/test file (in my example I used a .png)
    3. Click the blue SHARE button at the top right --> Click the FILE icon
    4. In the FILENAME box give your file a name such as TEST or DEMO and delete it later (after this process is complete)
    5. Select the file type from the dropdown menu SAVE AS TYPE that you want Snagit to default to (in my example I selected .png)
    6. Click SAVE
    7. From now on Snagit will default to this file type

    That's it, short and sweet!

    0
  • cyrusmd

    Gsimonis, it does not work like that in v2022. If I open a .jpg file and when I save as, it will try to save it as the original file format. I am looking for is when you open .jpg and I want my default save as .png to be used without selecting it from the dropdown menu

    1
  • grguthrie

    I am not sure if people here are discussing the editor or standard file saves.

    Standard snagit file saves on a capture - the use last format (JPEG) does not work. It always defaults to .snagx, even if that is not the selected option in the settings.

    1
  • Thebfm

    Gsimonis - Thanks for your help.

    Grguthrie - The solution provided by gsimonis is for the editor. If you select .jpg, the Save As function gives the suggested filename a .jpg extension but the file TYPE says it's saving as a .snagx file. Ignore what it says about the file type; it actually is saving as a .jpg.

    0
  • greig

    Surely that's a bug in 2022 Thebfm ?

    Giving the file a .JPG extension, telling me it's "sav[ing] as type" *.snagx - and still saving as a JPG?

    (That's why I'm here too. I upgraded and I'm in this save-As / file type mess.)

     

    \- G.

    1
  • Thebfm

    greig - I assume it's a bug. For me, I'll take whatever I can get - at least I don't have to click the down arrow to select the file type. I do still have to change the filename (not the file extension) from the default because I usually want to use a filename that applies to what I'm working on.

    0
  • greig

    Aha! Thebfm

    Save as always defaults to Snagx format – TechSmith Support

    When saving a file it does not respect the Save as preferences format

    Currently this is a bug in Snagit 2022.0.0 which we hope to fix at a later date.

    1
  • Thebfm

    greig - Thanks for the info.

    0
  • Perrorist

    This is not smart, Techsmith! I don't want to have to keep changing the file type from snagx whenever I save. It's an extra unnecessary step.

     

    1
  • David78737

    I agree with the above.  It's a bug or something to make our lives miserable.  Send out a celebratory email when you fix it.  Oh, thant might not be necessary.  It'll just work.

    1
  • mrbobmac

    I agree with the above. I find the default save as .snagx to be useless. Although I know it does that, after 18 years of having it save as .jpg or .png (as I desire), most times I forget to go through the hoops to change the file format e.v.e.r.y. t.i.m.e. As a result, when I go to find the screenshot, it is seemingly not there. I then have to go back into the Snagit Editor and do all the save steps again. This is greatly slowing down my work. It is a huge hindrance. Can I say that more strongly without offending readers?

    I have 10 months until my current subscription expires. I hope it is fixed by then, but if not, I will reluctantly say goodbye to what is probably my most used utility.

    1
  • greig

    The issue - or at least THIS instance of it - was resolved in 2022.0.1.15562, dated January 12th.

    Help / Check for Updates should flush it out for you (if you're not already auto-updating).

    To enable auto-updates, from the Capture app select File / Capture Preferences , General tab and check "automatically check for updates".

    1
  • mrbobmac

    Thanks! That does appear to solve it. I'm chilled now. :)

     

    0
  • cyrusmd

    The issue has been resolved in 2022.0.1.15562, dated January 12th. Thank you Techsmith for fixing it. Next would be to fix the size of the QAT to make them look like a normal program. Small or medium size and not giant like your software. Real estate is all about optimizing the screen display of your software just like your older versions.

    0
  • Sasha Samisnky

    Unfortunately, I encounter the same issue in 2022.1.1.
    Disappointing :(

    0

Please sign in to leave a comment.