Screen zooms to max magnification when I initiate a Snagit Capture

Completed

Comments

42 comments

  • Jason Eagleston
    Hi Jim,

    By chance are you running Snagit on one of the new Retina display MacBook Pros? If so, we are in the process of fixing a number of Retina-related bugs and releasing an update in the next week or so.

    Thanks,

    Jason
    0
  • Jim
    Yes, Jason, I'm running MacBook Pro with Retina display. Thank you for letting me know. In the mean time I'll just take full screen captures and crop in the editor.

    Crossing my fingers that the fix won't take too long.

    Jim
    0
  • Jason Eagleston
    Hi Jim,

    We released version 2.1.1 today! If you open Snagit and choose the "Check for Updates" menu item under the Snagit main menu, you should be prompted to update your Snagit.

    I hope this helps out. Here is a different post with more information about our plans for Retina support: http://feedback.techsmith.com/techsmi...

    Thanks,

    Jason
    0
  • Steve_Yacovelli
    Hi ... I have 1.0.4 and it says "up to date!" when I try and rectify this situation. I guess it's forcing me to buy yet another license?!!?!? Grrrrrrr ... no bueno TechSmith.
    0
  • Sally Townsend
    I am using a PC running Windows and i am having the same problem. Do you know how I can fix it?
    0
  • Jason Eagleston
    Hi Sally,

    We are unaware of a similar problem on the Windows platform. This problem was isolated to Snagit on Mac with the new Macbook Pro Retina Displays. If you are seeing a similar issue with Snagit Windows, please contact our technical support team for assistance as they will be able to better troubleshoot the problem.

    A support ticket can be opened here: http://techsmith.custhelp.com/app/ask

    Thanks,

    Jason
    0
  • rox.john
    I have windows 8 and the same problem is happening to me.
    0
  • Kol Birke
    me too
    0
  • Jacob

    I have found a fix for this reoccurring issue on my Windows 8.1 machine... uninstall and use a new program. After altering my resolution and display sizes for 6 months to accommodate SnagIt... I finally learned that help is not on the way.


    0
  • Jeremy Schembri
    i am having this same problem..
    0
  • todd.woodstra
    I have a Lenovo 910 running on an external monitor and have the same problem. I just upgraded to 13 and did not have this problem with 12. Help!
    0
  • tbeane
    Got this to work with SnagIt 11 on Windows 10.   Make sure the Windows display/magnification setting is 150% or lower. If using multiple monitors, make sure they have the same magnification setting.  After making the changes, you may need to log out of Windows and log back in again.
    0
  • rashid
    This worked. I had to change the Windows 10 magnification settings from 150% to 100%. Thanks for the tip! @tbeane
    0
  • romans12.9.heart
    I have an older version of Snagit (1.0.4) and it is saying that I do not have a paid license for the new version, is there a way I can update to work on my Macbook Pro Retina Display without having to purchase it again? Thanks!
    0
  • Garett
    Hello,

    I have SnagIt on my Mac with exactly the problem first described described above by Jim. I also have a  Mac with Retina Display.

    I have SnagIt through a corporate license. When I click on SnagIt > Check For Updates... It tells me that I have the most recent release. However, About SnagIt tells me I have version 1.0.4.

    I would love to have a working SnagIt on my Mac. Should I download the newest version from the web site?  Will my corporate license work?

    Thanks!
    0
  • Angela Terry
    I have used snagit regularly on my windows 8.1 machine and have not had this problem until today. Nothing has changed. Why all of a sudden is my screen zooming when I choose print screen!?
    0
  • mrshahid
    I am facing the exact same issue. :(
    0
  • PJPete
    I just received a new computer and Have the same issue I can no longer use Jing because the screen zooms so large it distorts my image. Since there is no help has anyone found another program that works? I have used this for years what a shame. 
    0
  • Kelly Mullins
    Hello,
    I'm sorry you are having trouble. Since the reason can be many things, please contact tech support and let them help you sort this out.

    Technical support is a Free Service and you can submit a ticket here:

    https://support.techsmith.com/hc/en-us/requests/new

    Or call, 1.517.381.2300
    Toll Free: 800.517.3001 (U.S. & Canada Only)
    8:00 AM to 7:00 PM EST Monday through Friday

    Kelly
    User Assistance
    TechSmith
    0
  • rzegarra
    I am getting this error on a SUrface Pro 3 that I just reinstalled. It was working fine before.
    0
  • jamesmanfredi
    I have this intermittent problem as well running a MacBook Air with a Retina display. Frustrating enough to look for a different screen capture software. 
    0
  • Michael Anderson
    Retina support for Snagit for Mac was added in 2.1.7 so you will have to be on that version or later for it to work correctly.  

    No current problems are known with Retina in our current version (3.3.4) so if you are running into issues please contact Tech Support (here: https://support.techsmith.com/hc/en-us ) so we can collect some more information.

    Thanks!
    0
  • Theresia Mallia
    HI I am having this problem on WINDOWS 8.1 any help please. as soon as I hit my 'printscreen' button it launches snagit and it zooms in I can't work any longer with snagit in this way pls help.
    0
  • Adam Marks
    Hello Theresia,

    Can you check the Help-About dialog to see what version of Snagit you have?

    I ask because in the latest versions of Snagit ( 12.4.1 is what I have ) we should be handling this better.

    If you have a significantly older version of Snagit like 10 or you may need to turn off DPI scaling in Windows 8.1 via the workaround listed here :
    https://feedback.techsmith.com/techsm...

    Thanks,
    Adam Marks
    Developer, TechSmith
    0
  • mhofert
    I am running Windows 10 on a new HP Elitebook and having the problem of the Screen zooming to magnification when I start SnagIt.   How can I correct?
    0
  • tbeane
    Got this to work with SnagIt 11 on Windows 10.   Make sure the Windows display/magnification setting is 150% or lower. If using multiple monitors, make sure they have the same magnification setting.  After making the changes, you may need to log out of Windows and log back in again.
    0
  • Mike Brown
    I only have version 9 of snagit and was forced to upgrade my company computer to windows 10.  am i now forced to pay for a snagit upgrade to work with this new os?
    0
  • twilder
    I am having this same issue. I am using JING version 2.9.15255 on a Surface 4, new windows 10.
    0
  • Fernando Alvarez
    Windows 10
    1. Right click on your Desktop and choose Display Settings
    2. Move the slider to the left so it is set to 150% or lower
    Windows 8
    1. Open the Control Panel and open the Display category
    2. Check the box to "Let me choose one scaling level for all my displays
    3. Set to 150% or lower
    Windows 7
    1. Open the Control Panel and open the Display category
    2. Set to 150% or lower
    0
  • Becky
    New laptop with Windows 10 build 10240. The magnifier setting is 125, still having the issue.  
    0

Please sign in to leave a comment.