Multiple display screen capture issues

Comments

24 comments

  • Rickstone1975
    Hi there

    You likely need to provide more detailed information. Just saying something is "weird" is open to all sorts of vague interpretation.

    Can you articulate exactly how it is weird? Is it possible to obtain a screen shot to demonstrate?

    Cheers... Rick :)
    0
  • s.rehmanale
    My bad:) I thought someone might have faced this before. I have three displays 
    1. Laptop_1920x1080: on this I have this thread 
    2. LCD_TV_1920x1080: on this I have google home page
    3. Samsung_3840x2160: on this I have Wikipedia home page



    Now when I click on the capture all three displays are turned into 1 display which is partially visible on each screens, may b attached images can help you to understand the issue. Clearly it not showing the first display in any of the screen whereas the second and third displays are trimmed on each screen.

    These screen grabs are taken from corner to corner instead of what jing auto selects.
    Display 1: https://www.screencast.com/t/WrjskmqyTLoY
    Display 2: https://www.screencast.com/t/bypg7XwMNJ
    Display 3: https://www.screencast.com/t/M6YE3JWqTjxn
    2
  • stephensterry853
    This is a guess on my part but I'm thinking it's the 4K monitor that Jing can't handle.
    Here's my 2560 x 1440 monitor followed by two 1920 x 1080 monitors. I captured them without issue.

    Jing is what it is.
    A functioning but  antiquated free software. It's copyright runs 2007 through  2012.
    4K integration was not that important in 2012. I seriously doubt Jing has the hardware under the hood to handle the display.

    SnagIt's wouldn't display correctly on 4K monitors until long after 2012. I'm don't remember when they fixed all that but it took a while.Jing can't record video in4K and still records in swf which is ultra antiquated. Although, if you send it to Camtasia 8. It converts it to an avi so you can edit it.
    Anyway, Sounds like you enjoyed the Jing free ride as about as far as it's going to take you in all likelihood.Might be time to think about sticking a pry-bar in the old billfold and getting SnagIt? I'm just kidding around here. But Jing isn't going to improve with age. That's for sure.

    Try temporarily reducing the resolution of the 4K monitor to 1920 x 1080. See if you can capture all monitors without issue.If you can, the 4K monitor is the problem. 

    Regards,Joe  
    0
  • dorothycandace
    I have this same issue.  Is there a solution?
    0
  • James Iliffe
    This same issue started occurring when I updated my Surface Pro laptop recently.

    I managed to resolve it by going to Display Settings > scrolling down to Scale and Layout > then adjusting the magnification from 150% (which is recommended) back to 100%.

    This has made the layout on my laptop screen tiny, but Snagit now works as it should.
    Hope this helps!






    0
  • Joanne Irwin
    Thanks for the  solution to change the magnification on the screen. this solved the issue for me except now my primary laptop monitor is near useless b/c everything is so small. 
    0
  • Todd Zessin
    Having similiar issue since I updated several months ago, running 3 monitors, 2 extended to the right and left of main.  when I run snagit, it condenses all 3 screens to the main and I can only snag off the main screen and when you click to snag, it only snags what is displayed on the main screen. prior to updating to version 2019.1.3 build 3847.  everything worked.
    0
  • Dilshod Niyozov
    I have the same issue. Me as a programmer was writing a software that captures the screen and not only Snagit, my screen captures has the same issue as well. I think If Microsoft gives a solution to get the correct width and height of the magnified screen, then things could work better. 

    0
  • santidavel92
    I was able to fix this by having the same Zoom % in Display Settings>Sacle and Layout.
    One monitor was 100% and the other one was 125%.
    As my smaller (laptop) monitor was 125%, I changed the other monitor to 125% and now it is working well.
    0
  • blackwec

    I'm reporting the same issue. The problem happens when you have two monitors using a different magnification. In my case I have a laptop with a 3240x2160 display at 200% scale. I have an external monitor at 1920x1200 but 100% scale. On either monitor it looks like the selection region shows everything shrunk vertically by 50%. On the 100% monitor, the capture itself is correct, however on the 200% monitor the capture only gets half the selected region. This is a huge problem, especially now that I'm working from home. It's not tenable to have my laptop display at 100%, the text is so small it's unreadable. I rely on Snagit to take screenshots for instructional materials I make for my job so it's been a drag :( 

    Since I couldn't use Snagit to take a screenshot I took a photo of the screen so you can see what's going on.

     

     

    0
  • Robert R.

    Hi blackwec;

    Unfortunately this is the case in mixed-DPI setting; for working with Snagit your displays should, ideally, be set at matched scaling percentages (though I've see Snagit work fine if the scaling differences are close, say 100% and 125%). This is something we are working to improve, but at the moment the recommendation is to set your monitor scaling to be as close to true native as you can.

    -Robert

    0
  • aching

    Thank you for shedding some light on this.  Resetting my display scales such that they are all the same percentages resolved the issue.  It was driving me nutz for a while.  

    0
  • BruceLarson

    I have found that I can have monitors at a different font magnification if I change the settings on snagit to 

    multiple area

     

    0
  • staestc

    At least I finally found a thread where somebody from TechSmity apparently participated, responded and at least acknowledged that the problem actually exists.  My issue is the same as most.  Working from home with a laptop with a very high resolution built in monitor at 250%(Recommended) Scale and desktop extended to two much larger but lower resolution monitors at 100%(Recommended) Scale.  I cannot adjust scales to any common value that  will allow Snagit to function correctly, and keep the monitors usable, nor can I find a set of close scale values where the monitors remain usable.

    No way am I going to pay for Snagit again while it has a known issue that makes it unusable in certain configurations.  $50 buck is a lot of money for a product that will only work in certain configurations but does not provide that information before purchase!

    0
  • Karen Hor

    Snagit used to work for ALL THREE of my monitors now when I choose to snag a region, it's WAY zoomed in on only ONE SMALL PORTION of the screen on ONE monitor. I'm caps-ing because I am frustrated. I rely on Snagit for work every single day. It used to work the same way if I drag my cursor from one monitor screen to another, and now it just gives me a super zoomed in portion of one screen on only one monitor. Can we PLEASE FOR THE LOVE OF TECHNOLOGY FIND A SOLUTION TO THIS.

    1
  • Robert R.

    Hi Karen Hor

    I'm sorry to hear that you're running into this issue; it is often the cause of outdated video drivers or an issue with DPI scaling. I'd be more than happy to open a support ticket for you so an agent can grab some diagnostic files and see if that's the case; would you like me to open a support ticket?

    -Robert

    0
  • janelle.gieseke

    I am having the same issue as Karen, just started this week. Has a resolution been found?

     

    Update: I found a support page listing this is a known issue. https://support.techsmith.com/hc/en-us/articles/203731188-Snagit-Windows-Capturing-Only-One-Screen-with-a-Dual-Monitor-Configuration

    0
  • aching

    @janelle.gieseke 

    The only fix that I am aware of is the one posted by blackwec (thank you), make the two monitors resolution %age the same.  If this doesn't work, my work around is to just hit printscreen (provided it is not your hotkey).  Windows will put an image of all your monitors into the clipboard.  I then paste it into snagit editor then just crop it down to whatever my snagit would have been.  Make sure to flatten the image at that point.

    0
  • carlene.wolen

    I am having the same issue and changing the resolution on my laptop is not an option as like many others, its just too small.  I changed my settings to capture the full screen on my monitor and then cropped what I need and carried on from there.  Its not ideal and being this has been an issue going back at least a year, you would think that TechSmith would have a better solution.

    0
  • Jason A

    Bruce Larson's workaround worked for me -- setting Image > Selection to "Multiple Area."

    0
  • Michal J

    have 3 monitors, all the same resolution and DPI (100%). When i screen capture from monitors other than the "primary" monitor i get a small window to capture and it's usually the screen from one of the other monitors. 

    Verified nvidia drivers are up to date. 
    DPI set to 100% on all 3 monitors
    Resolution set to 1920x1080 on all 3 monitors
    Removed snagit 2019, installed 2022, same result. 
    Tried multiple screen option, no change. 

    Any other suggestions?

    Screenshot below of the snagit capture window using snip-it. The grey area is the rest of the monitor screen not being captured by snag-it

    0
  • Bryan Bentz

    Run Snagit as Administrator and that should fix the problem. I upgraded to 2022 and this shifting crap drove me nuts. I tested it over and over even at different scaling settings so it should work. So Start button > type Snagit and the app should be found > right click on it and choose Run as Administrator 

    If you want to make it open as Administrator every time then choose open file location (it's just below Run as Administrator). That will open another window with the Snagit applications

     

    Right-click on your version and choose Properties

     

    Click on the checkbox to run program as Administrator. You can also make it run as administrator for everyone that uses the computer by clicking the button. Another window will open up and on checkbox to run as administrator. Click on OK to close out the window(s) and you are all set. 

    Now depending on your UAC settings you may have to click a box to proceed with opening the app as Administrator.

    4
  • Maciek

    Bryan Bentz, that's the only thing that worked for me as well, thanks a lot!

    0
  • Michal J

    Bryan - this worked... I initially just tried running the app one-time as admin, that did not do it but I think that's because it was already running in the background. Had to kill the app from the task bar > locate the shortcut > set compatibility mode to "run as admin" every time > now i can capture all. This issue has been driving me crazy for months... thanks for the suggestion. 

    0

Please sign in to leave a comment.