Transparent background not saving as transparent.

Comments

15 comments

  • rgrun
    What are you saving it as? SNAG PNG GIF and PSD are ones that support transparency (there are probably a couple of others that I never use. I think ICO also respects transparency)
    JPG will tunt the transparency to white. Try saving in a PNG if you have not already done so
    0
  • Diane Fallier
    I'm saving as a PNG. I was able to make the background transparent and save it in paint.net but it would be nice if Snagit worked for this.
    0
  • Greg Miles
    I was being driven mad by OPs same issue, but didn't realize (until reading your comment) that JPG was changing my transparency to white. Changed my settings in SnagIt 2019 (Share > Save As Preferences > File Format) to always save as png as transparency is something I am using constantly. Thank you Rick Grunwald!
    0
  • rgrun
    I just imported a cut out into snagit, saved it out as a PNG and it came up in Affinity Photo with a transparent background. 
    Is this what you were doing?
    Here is my export from Snagit to PNG.. If it is not coming up with a transparent background for you then the problem may be further down the line such as a setting somewhere 9I was not finished with this cutout so it is rough) I detached the pic below and it came up in Affinity with a transparent background
    0
  • Diane Fallier
    I was working on a logo setting the background to transparent. The logo looks fine as long as it's in Snagit. But when I save it and bring it back in to Snagit it's no longer transparent. I haven't tried it on any other graphic. 
    0
  • rgrun
    I have no idea of what happened but that did not have a transparent background
    This one does. I tubed out the white in the dingbat at the top right ...
    Save this and see if it does what you want
    I don't know to what extent you play with graphics but bringing the white background on top of a transparent base gives you a white background. All the white has to be removed. You should be able to use the bucket to "pour" the color "transparent" into the major white spaces
    0
  • Lee
    Hi I had the same problem. After much frustration I've found the solution. I figured that when you save you need to select Options in the Save As dialog and select the True color + transparency (32-bit) option from the Colors droddown list in the File Format dialog each time you save. I clicked on the Default to try and make this selection the default so that you don't need to do this every time you save. But it appears, the Default function is not working.
    0
  • Bpepin
    Thanks so much, Lee, for this post!  I lost WAAAAAY too much time trying to figure this out and finally came up with the right search terms to find this article. Hooraaaay!
    0
  • denyseturpin
    Thank you Lee!!  This started happening out of the blue, but I just clicked the default button, and it started working.
    0
  • mkrajewski

    Thank you - I don't know why that made a difference but it did...was tearing my hair out!

    0
  • markschieber4
    You're the greatest!!!!!
    0
  • rgrun
    Try going into the editor and from the menu SHARE / SAVE AS PREFERENCES / ALWAYS SAVE AS and choose the PNG format. The options button will light up and from there choose the tru color option and then ok
    Go back in and select last used it yo want that but the PNG depth should be set

    Someone may come up with something else but if not and mine does not work then You can Submit a ticket
           https://support.techsmith.com/hc/en-us/requests/new

    Or call, >>>

     Toll Free: 800.517.3001 (U.S. & Canada Only)

    8:00 AM to 7:00 PM EST Monday through Friday
    0
  • Dave

    This bug is killing me and it only just started. It seam like every time TS makes a new build they break something fundamental in Snagit for Mac. It's so tiring. Can TS just fix all the junk and leave it for a while? I tried some of these solutions but they look like they may be for windows? 

    0
  • Lucy

    Hello Dave,

    the canvas color option selection works on Macs, I just tried it. Right click on the background of your image, select "Change Canvas Color", click on the little square and there you can pick a color or transparent (the one with the grey and white squares). Select that one. Then save your image as PNG, and you should be good. 

    0
  • NQ

    Thanks so much, Lee, for: "when you save you need to select Options in the Save As dialog and select the True color + transparency (32-bit) option from the Colors droddown list in the File Format dialog each time you save."

    Worked for me immediately.

    0

Please sign in to leave a comment.