Serious bug in Snagit 2020: Can only take screenshot of desktop on Catalina

Completed

Comments

13 comments

  • Glenn Hoeppner
    Hi techsmith2,

    You need to make sure that Snagit has been granted the appropriate permissions to capture in Catalina. Please see this support article: https://support.techsmith.com/hc/en-us/articles/360034561752-Only-Desktop-Captured-Using-Snagit-on-M...

    -Glenn
    0
  • squirema
    The referenced article neglected to mention this, but under System Preferences, Security & Privacy, Privacy, Accessibility, you must also grant access to SnagItHelper2020 for the All-In-One Web Page capture to work correctly.
    0
  • squirema
    Also, in addition to the System Preferences > Security & Privacy > Privacy > Screen Recording reference in the aforementioned article, be sure to enable SnagIt 2020, in:

    o  System Preferences > Security & Privacy > Privacy > Camera
    o  System Preferences > Security & Privacy > Privacy > Microphone
    o  System Preferences > Security & Privacy > Privacy > Full Disk Access and
    o  SnagItHelper2020 found in System Preferences > Security & Privacy > Privacy > Accessibility

    as well.
    0
  • johan.ballin
    This was a frustrating issue! Glad I found a solution here. After upgrading to Catalina and relaunching Snagit it, I was prompted for a series of permissions. However, the two remaining ones (that I was never prompted for) were Full Disk Access and Screen Recording. Seems like an omission on part of Tech Smith or a bug. 
    0
  • Luke Griffioen
    Hi,

    Sorry this was so frustrating! What version of Snagit do you have? In the latest versions of 2019 and 2020 you should be prompted with a dialog on launch that gives you a way to fix each of these permissions. In addition, trying to take a screenshot should prompt you to fix the screen capture permissions.

    0
  • Michael Pietroforte
    You are right, it works now. Thanks! 
    You might want to display a notice if the application does not have the required permissions. Nobody can know this.
    0
  • Glenn Hoeppner
    Catalina should be showing prompts, but without double-checking right now I think it will only ask once. It's unfortunately also easy for those prompts to get lost underneath other windows.

    I'm glad we were able to get you working!
    -Glenn
    0
  • Michael Pietroforte
    I suppose you can verify if you have the required permissions whenever launch Snagit? I wouldn't rely on the OS for such an important function.
    0
  • nicolas
    Hi all, I checked all permissions and it does not work. I have to hard reboot my Mac .... Please, provide an update that fix the problem. Thks
    0
  • Luke Griffioen
    Hi,

    I'm so sorry we didn't reply to you sooner. If you open up a ticket with our Tech Support, they can help you out with the crashing issue.
    0
  • nicolas
    FYI : I cannot use Snagit anymore .... It always crash ... 5 reboots ... 
    0
  • mconneen
    WOW.. somewhat convoluted .. My SnagIT2020 was NOT showing up in System Preferences.   I verified I am on the latest update.   So, I had to 
    1.  Start SnagIT
    2.  Navigate to SnagIT / Preferences 
    3.  Click the "Capture" tab
    4.  Click on "Fix Capture Permissions" 

    A dialog opened and I had to click several "Enable" buttons.  

    Now .. all appears right in the SnagIT world.
    0
  • Walton
    When you're ready, click on the “Capture” button on the right end of the command bar. If you haven't upgraded to Mojave or Catalina, you can still save screenshots to your desktop as PNG files. To take a screenshot of the entire screen, press Shift-Command-3 myprepaidcenter
    0

Please sign in to leave a comment.