Clicking the red capture button on Snagit makes everything else on my desktop go away :(

Completed

Comments

4 comments

  • manny
    You are having a permissions problem.  You need to go to "Settings" then "Security & Privacy" and ensure that SnagIT is in the list of "Screen Recording" 
    0
  • cassandra.huidobro
    Fixed! Thank you so much, Manny! 
    0
  • squirema
    In addition to the System Preferences > Security & Privacy > Privacy > Screen Recording reference in the above comment, be sure to enable SnagIt 2020, in:

    o  System Preferences > Security & Privacy > Privacy > Camera

    o  System Preferences > Security & Privacy > Privacy > Microphone

    o  System Preferences > Security & Privacy > Privacy > Full Disk Access and

    o  “SnagItHelper2020" found in System Preferences > Security & Privacy > Privacy > Accessibility

    as well.
    0
  • cassandra.huidobro
    Perfect. Thank you, Squirema! 
    0

Please sign in to leave a comment.