Aligning two audio tracks without snapping to timeline

Comments

23 comments

  • William E Raymond
    I'm looking forward to seeing if someone has a good answer, but my trick is to just zoom in on the timeline a LOT and then the snapping is not as aggressive. I hope that helps.
    0
  • Stephen Wagner
    I am guessing that when you say 'snapping to the ruler' you are referring to frame boundaries.  In Camtasia the smallest unit of time we support is one frame.  If your frame rate is 30 frames per second, then one frame is one thirtieth of a second, and that is the smallest unit of time that you can move a piece of media.  Unfortunately there is no real work around for this.   You could up the frame rate to 60 fps, so you can get the audio a little bit closer, but we do not support sub frame audio editing.

    -Stephen
    0
  • Paul Sochan
    thanks for the quick response.  that brings me back to my request to have an automatic synch feature similar to Adobe Elements Pro (see my post referenced above).  I have a cleaner audio source, but synching the audio and video leaves the two sources slightly out of synch.  The result is kind of distracting, so i am now sticking with my inferior audio source.
    0
  • William E Raymond
    Hmmm.. I think I understand what you are talking about. Am I correct in saying you are cutting out unwanted audio (like awkward silences, umms, and ahhs, etc.)? If so, I wonder how you are doing that. Use COMMAND+SHIFT+X to do that kind of editing so all the tracks shift left. I'm not sure if that helps, but want to make sure it isn't something easy :-)
    0
  • Paul Sochan
    well i'm starting out simply wanting to perfectly align two audio tracks.  I used the "clap" trick to get a visual spike in sound.  But i can't perfectly line that up.
    0
  • William E Raymond
    And by "enable timeline snapping", I mean turn it off.
    0
  • William E Raymond
    Maybe go to View->Enable Timeline Snapping and turn that off. Should help. Otherwise, use my zoom trick (attached).
    0
  • Paul Sochan
    Yeah, i turned off that option.  and I zoomed in all the way.  Unfortunately, the audio is still mis-synched a tiny notch which i find distracting.  I've used the visual line up technique before.  It worked ok when it was voice over a screen capture.  But when i can see sombody's lips moving and it doesn't perfectly match the sound, it is distracting.
    0
  • William E Raymond
    I hear you and I can't help you much more than how I have so far. I think you previously posted that you use Zoom (or some other recording tool?) and if that is the case, you can always stop recording after everyone is online, then start recording again as you start so there is perfect alignment. WHen you record a Zoom session, it only starts recording people as they come online, forcing you to align afterward, but by stopping and starting, you get a new set of files that will align perfectly. Hope that helps.
    0
  • Paul Sochan
    thanks for the help bill.  In this case, I was trying to line up a recording from a video camera with an audio recording i have from a separate device.  i think i have done everything that i can.
    0
  • davemill
    Paul,

    Read Stephen Wagner's post above. Camtasia snaps to 1/30th of a second frames. It is possible that your camera audio and the audio from the other device are out of sync by that much. But when that happens to me, I never see the lips move out of sync. It's too short of a difference (about 1/60th of a second one direction or the other). 

    Can you zoom all the way into the clap on your timeline and send us a screen capture of the out-of-sync claps? 
    0
  • KenTheriot

    I'm having this same problem. I'm zoomed all the way in and can't sync up 2 audio files because of the snapping that still remains. Why can't it be completely turned off?

    0
  • davemill

    Ken,

    If you are zoomed all the way in, Camtasia is shifting the track by one frame (1/30 of a second) per "snap." This is inaudible, especially since the maximum misalignment is 1/60 of a second. Although it seems unlikely (maybe you are trying to detect gravity waves from a distant black hole collision?), if you need to align more accurately than that, you need to use an audio editor like Audacity or Audition and set the resolution to something less.

    0
  • KenTheriot

    Yes I am totally zoomed in. Ironically, I'm teaching how to use an audio program (though for syncing/multi-track stuff I use Reaper, and Adobe Audition for fine editing of the "Audio Only" shares from Camtasia) with Camtasia videos. The only reason I'm needing to sync audio from the System Audio track to the edited (in AA) overall audio track is that the system audio recorded during the Camtasia recording sounds terrible for some reason. This is in a separate thread here. 

    So I render the good version of the audio from Reaper, import it into Camtasia, and insert THAT onto the system audio track. This is obviously MUCH more time-consuming than it should be. But until I have a solution for the system audio quality problem in Camtasia, I'm stuck with it. Anyway, since ALL the audio is now on the main audio track (since sharing Audio Only from Camtasia mixes all audio into one file), I'm silencing the bad-sounding system audio sequences in the main track, and using the imported "good" version of that passage in the track under it. But it needs to sync up. And I can't get it to do that. There is always a difference of a quarter or 8th of a second no matter how zoomed in I am. 

    Fortunately, the slight offset of audio from video in this case is not too terrible a problem. The students need to see the audio file in Reaper playing, but if the cursor in Reaper is an 8th of a second off, it's not that noticeable. But I thought I'd exhaust

    0
  • davemill

    Ken,

    I don't understand why you can't move your audio clips by one frame at a time. I just tried it on several clips at several zoom levels, it works great, no need to zoom all the way in.

    I prefer to leave Snapping turned on, it saves a lot of effort. To disable snapping to nearby edges with Snapping is turned on, press and hold Control AFTER starting to drag.

    0
  • KenTheriot

    I don't know. I'll try to make a video tomorrow. Interestingly it seems to be a chance thing. Some audio clips (especially the short ones) line up OK. the longer ones (20-30 seconds) are the ones that only jump from a little bit too late to a little bit too early. I just don't understand why it has to jump by frames anyway. I can do a totally smooth slide in Vegas Pro video editor. And of course any audio program.

    0
  • davemill

    Could the longer ones be snapping to something at their far end off-screen?

    0
  • rich

    I regularly align multiple audio/video tracks and cut back and forth between different cameras, with a "best" audio source typically coming from a lav mic recorder. I bring in all of my media onto the timeline and align all the tracks before any further editing. I split the audio tracks from the video tracks, zoom all the way in, set the play head one frame left or right of the beginning of the clip I want to move, and then drag the clip to snap to the play head (which is one frame away). This has worked fine. A keyboard nudge shortcut would be awesome, but since this feature doesn't exist, I use the above steps.

    (Of course, if your sync is off more than a frame, just move the play head the appropriate number of frames away.)

    0
  • KenTheriot

    Thanks. That's pretty much what I'm doing. It just seems that there is no way to completely freely move audio clips without SOME kind of snapping. As long as I know that, I can work around it. Of course, if I find a way for the audio quality on the System Audio track not to suck, I won't need to replace it. Like I mentioned above, that last issue is on another thread.

    0
  • jack

    Not being able to turn this off completely so that audio tracks can be moved by less than a frame at a time is quite annoying. Having to use an external audio program just to align two audio tracks is quite frustrating. 

    1
  • KenTheriot

    Totally agree!

    0
  • ndypnd

    I have the same problem.   Let me explain since some of you are thinking only in terms of lips moving.  I am trying to make video of musicians playing 30 fps is 30 milliseconds delay.  Now that may sound like nitpicking but to musicians that is the difference between good time and lousy time.  Musicians that are 30 miliseconds behind or ahead of the beat are pretty lousy sounding musicians.

    So I have an video track and I have several audio tracks - one audio track is the click or metronome track that all the musician's audio tracks need to sync with.  So I can line the video up closely enough to the click track so the lips seems to move in time - but if I had two musician's clicking drumsticks (for example - or claves - or bongos) and the audio is snapping to the nearest 30fps, there is an obvious echo between the two musicians so they sound like they cannot keep time with each other.    

    I totally understand why video snaps to 30fps but why does a separate audio track need to snap to anything?  The separate audio should be free to move without snapping.  I shouldn't have to go back to my Audio software (outside of camtasia) and trim 20 milliseconds off the beginning of the audio and then drag the audio back into Camtasia and see if it lines up now when Camtasia forces the snapping.  This is just silly --- if the audio is separated from the video there is no reason for the audio to be forced to snap to the video's frame rate.

    0
  • byronminick

    I am in full agreement with ndypnd’s comment. I ran into this very issue after exporting the audio to Adobe Audition, in order to clean up the audio. I have a few industry-standard plugins that will clean up the audio sound in order to give it a clean and crisp clarity. When you go to reimport the audio into Camtasia, it puts the audio off sync slightly, just enough that you’ll see the speaker’s mouth move, and then a brief moment later, you’ll hear his voice. The mouth movement and voice don’t match. Camtasia needs to add the ability to gently nudge the audio to the left or right until it matches the original audio’s positioning.

    0

Please sign in to leave a comment.