Windows Snipping Tool overrides Snag it! as the default when I hit Print Screen

Comments

41 comments

  • jnhaffey

    I seem to be having a very similar problem.  SnagIt was working just fine and then at some point in the last week or two, the Snipping Tool seems to have taken control over the 'print screen' key.  I have tried everything I could think of (or find online) to force the key back to SnagIt with no luck.  Any help would be nice, please.

    0
  • rob

    Basically the same problem here - snip & sketch (the Windows 10 replacement for snipping tool) has sort of taken over - but weirdly when pressing the prtscrn key as I would normally - Snip&Sketch AND SnagIt are invoked...

    0
  • mstam3056

    This is happening to me too. 

    When I set SnagIt to a different key, it pops up, but I am not getting it to "snap" to windows any longer. I can make a free form screen grab, but for some reason SnagIt has lost the ability to "snap" to windows on my desktop to make a clean capture. 

    I cannot see anywhere in Windows to turn this new capture off. The screen goes black and a small bar appears on my main screen with a few options for the type of capture - I think this is the new Snip and Sketch tool. There are loads of instructions online to disable the old "Snipping Tool" - but this Snip&Sketch seem hard coded and are messing up SnagIt. By the way - Screenpresso (a competing tool) is also interfered with (I have licenses for both but use one at a time). 

    I hope someone at Techsmith can give us some workarounds. 

    0
  • jnhaffey

    To add to this, I went as far as Uninstalling and then ReInstalling SnagIt with the hopes that whatever registry setting or configuration that had been 'messed up' would be fixed.  No luck though as the Windows 10 Snipping Tool still seems to have full control over the print screen key.

    Something I have also noticed, when I first re-installed the 'hot key' was listed as the Print Screen key but after a reboot, it went to blank. When I attempt to set the print screen key not only does the Snipping Tool activate but the key listed in SnagIt is 'LWIN' which does not make any sense.

    0
  • Raphael Lallemand

    Hi, exactly the same issue here, spend hours to try many things without success. 

    0
  • Robert R.

    Hi Folks;

    For those that are running into this issue, please exit Snagit by going to File - Exit Snagit (not by pressing the X in the upper right corner of the window as that will not exit Snagit). If the Editor is open then I would like you to go to File - Exit Snagit Editor (rather than the X in the upper right corner of the Editor).

    Once Snagit has been fully exited and is no longer running in the background (you can verify in the Windows Task Manager), I would like you to go to C:\Program Files\TechSmith\Snagit 2021\ and locate "Snagit32.exe" then right-click on it and choose "Run as Administrator" as seen here. Once Snagit starts with elevated privileges, please set the hotkey to Print Screen then verify that the option to "Allow Snagit to override other hotkey assignments" option is set int he "Hotkeys" tab of the Snagit Capture Preferences (via File - Capture Preferences, see here).

    Once verified and set, please go to File - Exit Snagit before attempting to capture (please exit Snagit in this manner rather than the X in the upper right corner). Once you've completely exited Snagit, please launch it via the desktop/taskbar/start menu shortcut. Does Snagit retain the Print Screen hotkey?

    -Robert

    0
  • jnhaffey

    Hi Robert R.,

    I will be honest I was really hopeful that your solution would work but sadly it did not. I seem to have this odd behaviour that when I click the Print Screen key (to set the hotkey) it is being listed as LWIN which makes no sense.  To add to the mystery here, this is only happening on my personal laptop but on my work laptop, SnagIt is still working exactly as expected.  I do not think it is SnagIt's fault or issue but something Microsoft has done with a recent update.  Sadly I have no idea which updates or even why this would be happening now.  The fact that I have uninstalled SnagIt and re-installed fresh yet still have the same issue makes me think that Microsoft/Windows has done something that is preventing this.

    - Jason

    0
  • Robert R.

    Hi Jason

    I'm so sorry to hear it didn't work for you! I'm curious- are you using a US-English keyboard? I am wondering if Windows thinks you're maybe using an International Keyboard (or vice-versa). Are you using an external keyboard or a laptop? If external, would you happen to have the make/model of it (it'd likely be on a sticker on the underside of the keyboard)?

    What version of Windows are you currently running? I think steps might be mildly different between Windows 10 and 11 and I just want to make sure I get the right steps for you.

    Thanks!

    -Robert

    0
  • Raphael Lallemand

    I tried also to follow the steps but i does not change anything. I still have Snipping tool starting when I hit the prtscn keys. 

    Another strange behavior, is that if I want to reassing the prtscrn key to capture.  go to edit the field under the big capture button, then hit the key, I have the value Lwin populating the field and not prtscn. 

    0
  • jnhaffey

    Hi Robert,

    Spot on thinking, the problem is not solved yet but based on your thought and question I tested something and now have slightly different results.

    Yes, I am using a Logitech Bluetooth Keyboard but when I try to set the Print Screen as the hotkey from my laptop's keyboard, I get an error that it is already set.

    I took your previous advice and attempted to set the hotkey after running SnagIt with Admin rights, it accepted the laptop's key input as Print Screen.  When I attempted to use the Print Screen key on the laptop keyboard it worked as expected.  When I attempted to use the Print Screen on my wireless keyboard, the Snipping Tool comes up.  I have now figured out the issue is in the Logitech software so will be reaching out to them next to figure out why it is doing this.

    Massive thank you.

    - Jason

    0
  • Raphael Lallemand

    Hi Jason, 

    FYI , I also have a logitech MX keys keyboard connected (bluetooth) to a dell laptop. when using the prtscren key from the laptop keyboard, it finally work fine, I was able to setup the capture hotkey to prt scrn.  but when I use the corresponding key on the logitech keyboard , it send a Lvm value, and still starting snipping tool. 

    I did not get the same behavior with the same keyboard connected to my desktop ! 

    0
  • rob

    I have a desktop PC with a logitech MX keys keyboard (UK layout) attached via a logitech unifying receiver, and have the same problems.

    0
  • jnhaffey

    Interesting, Raphael and Rob are you both by chance using Options+?

    FYI, I did raise a case with Logi yet the response from Support was...well really pointless.

    https://support.logi.com/hc/en-us/community/posts/4412587970455-Print-Screen-Button

    0
  • Raphael Lallemand

    I just realised I may have a different release of the the logi option software installed on both. I had installed the new logi option+ (beta) on the laptop with the issue. I'll try to uninstall it. 

    0
  • rob

    I am using Options+, yes.

    0
  • jnhaffey

    Raphael, you and I have had the same thought. On my personal laptop, I am using Options+ but on my work laptop, I am using options. My personal laptop is having all the issues where as my work laptop is working as expected.

    0
  • Raphael Lallemand

    same but the oposite (work vs personnal) , good news is , I unstalled option+ from teh laptop, and after the reboot . everything back to normal. the prtscrn key from the logitech is functionning as expected . no more Lwin.. et no more snipping tool ! 

    We made it !  a good team effort 

     

    0
  • jnhaffey

    Excellent work Raphael.  Now if I can just convey this to Logitech so they listen...LOL

    0
  • mstam3056

    Remove logi-options+ and the problem goes away. Just stick with Logitech options and snagit I can confirm works as it should.

    0
  • Trec-mats

    I add this to bring some more words to Google for other users' search. I have to add one thing: On my Dell precision 5540 with Swedish Windows 10 I got the almost same thing:

    1. The prtscr (Print Screen) didn't react at all - it was dead no matter what.

    2. I got Logitech Options (not Options Plus) for using Flow between my two laptops.

    3. I could not add the Print screen key as Global Capture hot key in Techsmith Snagit 13. No reaction at all.

    Solution:

    1. I set Logitech Options as Inactive in Startup and rebooted the laptop.

    2. After reboot I could add the prtscr as hotkey for Global Capture in Snagit and the key worked as it used to, to capture.

    3. Activate autostart of Options in startup and reboot.

    All still works fine - both Prtscr, Snagit and Options with Flow.

    Thanks for all tips!

    /Mats - Sweden

    0
  • Paul A Vitagliano

    Unfortunately, NO luck with any of the above. No matter what I do, Snipping Tool rules. Knocked OneDrive (already disabled the snip and save option), Logitech (don't use Logitech Options), any Snagit settings out of the equation. Tried every step above. One PC is a Windows 10 (latest) with Snagit 2021 (latest). Laptop has Windows 11 (latest) with Snagit 2021 (latest) - and same issue - Printscreen key will only activate Windows snipping tool. I even uninstalled the Snipping Tool app. When I did that, the Printscreen key was rendered useless. Would not do anything, despite Snagit settings.

    So FYI Techsmith team - the setting for having Snagit supersede and overtake the Printsceen key is not working. It used to, but it appears that maybe a combination of Snagit updates and Windows 10/11 updates has broken that feature.

    Can you please address this? In the interim, is there anyone who knows a Windows Registry edit that will force the Printscreen key to activate Snagit Capture? 

    PLEASE help. :)

    Paul V. - Boston MA

    0
  • Luis1991sag

    1. Run Snagit

    2. Under the File menu, Choose the Capture Preferences option.

    3. Uncheck the Open screenshots copied from System Tools checkbox …

    Now you can snip in peace without the Snagit editor popping up.

    0
  • Paul A Vitagliano

    With deepest respect and love, Luis, that answer has absolutely nothing to do with my issue. Where in my post does it say anything about pop ups from the Snagit editor? 

    0
  • Benmmadsen

    Not sure whether this is an ongoing issue for folks on this thread, but I was able to solve it on my device by ensuring that I had Snagit editor as on of the apps set to launch on device startup. 

    0
  • Paul A Vitagliano

    Benmmadsen Yes - past that.

    0
  • R Raveendrarajah

    @Paul A Vitagliano

    Not sure if you've found the solution, but here's what worked for me.

    Under Logitech Options, change your keyboard setting of the 'PrintScreen' button back to Printscreen. 

    Because by default (I think Logitech Options) sets it to 'Screenshot Tool' which by default is the Snipping Tool. 

    Once you you do this - it will be recognized as a PrintScreen Button and then you can set it as such on Snagit.


     
    0
  • Paul A Vitagliano

    Doesn't work if you don't have a Logitech device attached to your computer.

    After all these months, this problem continues. Techsmith sends out tons of updates, but they won't fix this issue OR the issue with pressing ctrl + del to get a Snagit delete window.

    Fascinating. None of this would be going on if I ran this company, I assure you.

    0
  • Utomo

    This is my solution. It solve the problem

    Open Snagit
    File 
    Capture preference
    Hotkey

    Check the Allow Snagit to overide the hotkey assignment

    Good luck

    1
  • Paul A Vitagliano

    Let me guess - you work for Techsmith. Your answer is about as substantive as theirs.

    0
  • nbaunis

    Apparently my Lenovo Ideapad had set the prtsc key to snipping and I can't find a way to disable it. My solution is to use Fn + Prtsc. 

    I tried everything. Accessibility setting, uninstalling the snipping tool altogether. It still came up.

    The Lenovo forum suggested using a third-party remapping tool to disable but as a normal non-techhie user that is not an option I like. I will live with Fn+Prtsc.

    0

Please sign in to leave a comment.