The TechSmith User Community is closing on January 3rd, 2024, and the ability to create new posts or add comments has been disabled. To learn more about alternative support options, visit our Support Center. Product feedback can be submitted here.

Disable cursor capture in SnagIt 2022




  • Official comment

    Hi dsdalal - you can switch off cursor capture using this toggle in the Snagit Capture window:

  • dsdalal

    Ok, I'll check that setting, thank you.

  • HappilyFreckled

    I have the "capture curser" toggle turned off on all those tabs in the screenshot above, but it's still capturing the curser. Can't figure out how to make it stop doing that.

  • Jacques Dubler


    I have the same abnormal issue. On my Snagit Capture window I have the "Capture Cursor" toggle turned off and still my cursor appears on all my captures. Anyone knows how to solve this unpleasant problem? Many thanks in advance for your support.


  • Sheldon Wong

    I am experiencing the same issue on macOS with the Capture Cursor control turned off as others have shown and take a look where the pointer is captured as two items, a smaller one captured ontop of a larger one. The larger pointer is the size I have adjusted through the macOS Accessibility settings and the smaller pointer is the normal sized pointer but only the larger one actually shows onscreen so not sure why the smaller one is also appearing - still I don't want to see either in the capture.

  • Cpreid

    I'm getting the same issue on Mac also, driving me crazy having to remember to move the cursor out of the way of the screen I'm capturing.  Has anyone had an update on this one?

  • Sheldon Wong

    So after more testing on my own, it looks like my issue for the cursor being captured (even when the toggle is OFF) may be related to the DisplayLink drivers I'm using to get my Macbook Air (M1) to support two external displays (when natively, without DisplayLink the Macbook Air M1 will only support a single external display). So long as the DisplayLink driver is active, the cursor or arrow will always show in a Snagit capture no matter which display I use (two external or laptop display) but once I disable/quit the DisplayLink driver the cursor or arrow will respect the setting for the "Capture Cursor" toggle. I reported this in the case I had open with TechSmith but the person looking at my case did not indicate they would be trying to address this glitch. This could be an issue with how the DisplayLink driver works combined with how Snagit works but since DisplayLink is a work-around to overcome an unsupported use case, I'm not sure anything can be done in my situation. 

  • MeierIT

    I use a laptop with it's lid closed and an external monitor. Same thing happens it captures the cursor even when the cursor capture toggle is off. It's quite annoying as you usually need to do another capture quickly moving the cursor off screen.

    Would love to see it fixed.


Please sign in to leave a comment.