An error occurred in the Recorder: Resource Allocation Failed

Commentaires

14 commentaires

  • wprine

    What's your system like: OS, memory, etc.? Does your camera have a microphone?
    0
  • SSA-Ed
    First make sure the devices you want to use are listed in "Device Manager". Then in [Control Panel], [Sounds] - Playback tab make sure the speakers or headset you want to use are listed and one is default.
    On the recording tab, make sure the device(s) you want to use are listed and only one mic is default.
    On both tabs, if you notice a device you never use, you can rt-click it and disable it.

    I have a Logitech C920 Web Cam  which has a lousy mic, but if I plug in the C920 just before starting a recording, Camtasia will default to the C920 camera and mic, yuk. If I plug in my Plantronics C435-M after the Camera, Camtasia will default to the C435-M mic.

    Best practice when starting Camtasia - always check the "recorded inputs" to make sure the mic you want to use is selected in Camtasia. 
    0
  • Aldo3ortiz

    Hello there!

    First of all, thank you!

    My system is pretty good: Xeon 18 cores, 64gb, 256 SSD, etc. My camera is a Logitech with a microphone in. In fact, everything was working perfectly a month ago when I bought a Radeon RX 570 8gb and replaced my NVidia 2gb. Unfortunately, I don’t remember for sure if I’ve used Camtasia since the upgrade. I don’t think so. It’s been very busy for me the last three months. So, I really believe last week (last Saturday) was the first time I tried to use Camatasia + Camera + Mic. And as I wrote before, the problem happens only when I try to use the Camera+Mic. If I skip one of them everything runs fine. The best guess is the AMD Software, the Radeon RX 570 driver/software, right?

    Anyway, I think that’s it.

    Once again, thank you!
    0
  • SSA-Ed
    Perhaps a re-install of Camtasia? (It may need a re-install for the new video drivers?)
    If that doesn't work, remove the RX 570 and try the nVidia card again?
    0
  • Aldo3ortiz

    Hello everyone!

    I’ve just found out that the problem happens only when “Screen recorder + Cam + Mic” are being used at the same time. I made a short video using the “Record Camera...” that option we have from the “Tools” menu. Both video and sound worked and my short video was perfect.  Anyway, again, the problem is when I try to record my SCREEN + CAM + MIC all together:

    ***

    CAM + MIC = ok!

    SCREEN + CAM = ok!

    SCREEN + MIC = ok!

    ***

    SCREEN + CAM + MIC = error message!!!

    ***

    Thank you again!!!!
    0
  • Aldo3ortiz

    Thanks Ed!

    It was a really good tip. I was checking out my system and I had my monitor’ speaker on, but I use an external speaker. So, for couple minutes I got so happy thinking the problem was solved: two devices being used at the same time, right?

    I turned off my monitor’ speaker and checked out everything else to make sure I have only ONE input and ONE output for sound system.

    I reboot the Windows and, unfortunately, the problem remains.

    Thank you anyway!
    0
  • Aldo3ortiz

    CAM + MIC = ok!

    SCREEN + CAM = ok!  error message!!!!

    SCREEN + MIC = ok!
    0
  • Aldo3ortiz

    Thanks again Ed!

    **********

    Perhaps a re-install of Camtasia? (It may need a re-install for the new video drivers?)
    If that doesn't work, remove the RX 570 and try the nVidia card again?

    **********

    I’ve done a re-install already. I’ve also done a re-install of my Snagt 11. I thought the Snagit was interfering some how, but not.

    What I haven’t done yet is the hardware part. I haven’t tried to reinstall the nVidia one.

    I’m trying everything possible first but hardware.  This will mess up my work/time right now. So, as much as I can, I want to avoid it.

    Anyway, thank you very much!
    0
  • SSA-Ed
    OK - It's time to try the video card swap. If the nVidia works, you have pretty good reason to 1) check your BIOS and 2) call AMD (Radeon). Intel chips at times don't work well with AMD video cards, (and nVidia don't work well with AMD chips) but AMD may have a solution - it may be in BIOS or putting the video card slot_2 or slot_4. But if your not crazy about playing with the BIOS call the MB manufacturer.

    I had a similar problem this last summer and after 7 weeks of fighting the thing, ASUS stepped up and sent me a new motherboard - it was a night and day experience, terrible to wonderful.

    One other thing, is the camera and mic. If on a USB 2.0 port, switch it to a 3.0 port. If it's on a 3.0 port, put it on a 2.0 port. And make sure there's nothing plugged into a USB port that shares the same controller, i.e. make sure it's not next to the camera/mic connection. (i.e. Two connection share one controller.)
    0
  • SSA-Ed
    It just occurred to me but what mic do you want to use?  I much prefer my headset's boom mic, much better quality and I never want to use the camera's mic - which is disabled.
    In Camtasia before you start a screen recording are you checking which devices will be used?
    Please be precise (camera+camera's mic) is not (camera+mic), OK?
    Do you have a mic other than the camera's that you could use? Do you use a headset? (instead of speakers)
    0
  • Aldo3ortiz

    Hello Ed!

    I’ve tried that as well. I’ve tested two different kinds of mic: an usb one (Samson Q2U) and the input line of my sound card with a shitty mic – just to see if it works.

    And of course, I set up these mics on the Camtasia Recorder. I assume when you do that, automaticly you turn off the webcam mic, right? So, my assumption is: I was using the webcam VIDEO, but not the webcam MIC.

    My situation so far is:

    CAM + camMIC = OK

    SCREEN+ camMIC = OK

    SCREEN+SamsonMIC = OK

    SCREEN+LineinMIC = OK

    SCREEN + CAM = error message!!!

    SCREEN+CAM+camMIC = error message!!!

    It is a VIDEO problem for sure. I’m going to contact AMD to ask them how to turn off the Radeon RX 570 software without causing any problem to the drivers.

    That’s my best call so far.

    Thank you very very much!!!
    0
  • SSA-Ed
    Hello Aldo! 
    Now we're getting somewhere!!
    ". . . I assume when you do that, automaticly you turn off the webcam mic, right?"  No !  
    If you don't disable it, Camtasia may use it by default! 




    My Web cam mic is disabled (top red arrow) and will NOT be usablee until I manually re-enable it.
    My Plantronics Headset mic is enabled and becomes the default mic whenever I plug it in (USB). I have ni mic, unless it's plugged in.

    I can only assume your getting these errors:
    SCREEN + CAM = error message!!!
    SCREEN+CAM+camMIC = error message!!!

    Because the Cam mic is always on. i.e.  CAM = CAM+camMIC.

    Once you disable the Cam mic, start all over. Try with the Radeon card, etc.



    0
  • Aldo3ortiz

    Hi Ed!

    Everything is working fine now: Screen + Cam + CamMic.

    I did as you showed me and turned off all the Mic Recording inputs on my Windows Sound Setup.

    I tested all of them following your instructions and I figured out the F problem, but... you’re not gonna believe this.

    All this time, it seems the problem was my 4K screen.

    I didn’t even know the 4k screen could be an issue.

    And I feel so stupid for not realizing that before or even for not sharing this information here. I’m sorry.

    I’m saying that because all this time I was trying to do a “Full screen” capture + Cam + CamMic.

    And going for all these setups you’ve been helping me with, accidently, I did a “Custom” area capture of my screen and everything worked.

    My final conclusion so far is that Camtasia 8 is not compatible with 4k resolution. Am I right?

    Well, because that’s how it is working now. It doesn’t matter the mic, it is working when I do “Custom”. And it is still not working  when I try to do a “Full Screen” capture.

    Anyway, I wouldn’t have made it without your help. Thanks to your inputs and instructions I could dig here and there and ended up coming across this problem.

    Once again, sorry for not mentioning that my monitor is a 4k screen.

    And thank you very much!!!
    0
  • SSA-Ed
    " . . And it is still not working  when I try to do a “Full Screen” capture."
    at 4K?  I think you should take advantage of a Camtasia 2 week free trial and see if 2019.x does the trick for you.
    ". . .Once again, sorry for not mentioning that my monitor is a 4k screen." Even had you mentioned it, I may not have connected  the dots!
    0

Vous devez vous connecter pour laisser un commentaire.