Snagit (Windows): Video Playback in Snagit Editor Shows up Blank

Problem

After recording a video, there is nothing showing up in the Editor. The playback controls may show and the video appears in the tray, but no actual video is shown.

Solution

There are different issues for this behavior. The most common issue are the outdated drivers for video and audio hardware on the computer. Please try the following options if you are experiencing any of these behaviors.

Tip: Save Video and View in Media Player

In many cases, saving the video from Snagit Editor (File > Save As) and then viewing the MP4 to your default media player (Windows Media Player) will playback the video.

Option 1: Minimum Requirements

Make sure that the system you are using meets the minimum requirements for Snagit and video capture.

Option 2: Update System Drivers

Many issues can be resolved by updating the hardware drivers on your computer. This is done by visiting your computer manufacturer's support site and looking up your model computer to see if there are any updates available.

While Windows attempts to find these automatically, there are more recent ones available.

Some of the most popular manufacturers' support sites are:

Option 3: Audio Devices

Even if audio is not recorded, this behavior can be caused by problems with audio hardware in the computer or external hardware that is attached to the machine. To resolve this issue, follow the steps below:

  1. Disconnect any third-party devices.
  2. Restart Snagit.
  3. Record a new video.

Option 4: Change Performance Settings

Many laptops have a way of adjusting the overall performance of the machine.

  1. Press Windows+R on your keyboard to open the Run window.
  2. Type the following and click OK: control panel
  3. Select Hardware and Sound > Power Options > High Performance.SnagWin_PerformanceSetting.png

Option 5: Contact Support

If all else fails, submit a ticket to our support team for further assistance.