Manage Your Recordings and Project Files

Follow these file management best practices when setting up your first Camtasia project (TSCPROJ).

Camtasia File Types

File Format Description
Recording Files (TREC)
c2018-trecicon.png

Default file format produced after recording in Camtasia Recorder. TREC stores audio, screen recording, camera recording, and metadata into a single package.

TREC files can only be opened in Camtasia.

Project Files (TSCPROJ, CMPROJ)
c2018-tscprojicon.png

Video project file that saves any edits completed on the timeline and references the location on your computer of any recordings and source files in the Media Bin.

 

Open the TSCPROJ project file at any time to update, collaborate, or produce a video to share.

TSCPROJ/CMPROJ files can only be opened in Camtasia.

File Management Tips

Video file management can be overwhelming. Here are some tips and common workflows we use at TechSmith to help you get started:

  • When starting a new video project, set up a directory to save all the source files such as audio, recordings, scripts, etc. into one location for your video project. Here's an example folder structure:
    c2018-directoryex.png
  • After recording, move the recording files (TREC) from the default Camtasia folder into your video project directory. To skip this step, you can set Camtasia Recorder to prompt for a file name and location after recording, see Manually Save Recordings.
    c2018-moverecordings.png

    To add recordings and other media into your video project file (TSCPROJ), select Camtasia > File > Import > Media. Select the files in your project directory. Camtasia imports the files into the Media Bin.
  • To archive a video project, create a backup, or to move the project to another computer, select File > Export as Zip (Windows) or File > Export for Windows (Mac) to save the final project as a ZIP file. Make sure to select the Include all files from Media Bin in zip option to save a copy of the source files in the Media Bin in the ZIP file.

    Make sure you can open the zipped project in Camtasia (File > Import Zipped Project) and that the project contains all of the source files before deleting any files from your computer.

  • Do you frequently reuse the same video assets? See Find and Organize Assets to learn how to save assets to the Library for reuse across all of your Camtasia video projects.

 

Manually Save Recordings

By default, Camtasia automatically names and saves all TREC recordings to the Camtasia folder located here: C:\Users\username\Documents\Camtasia.

 

You can configure Camtasia Recorder to open a Save dialog to enter a file name and location for each TREC recording file after recording.

  1. In Camtasia Recorder, select Tools > Options.
  2. The Tool Options dialog appears. Click the File options button.
  3. Select the Ask for file name option.
  4. Click OK.

After stopping the recording, a Save dialog appears where you can enter a file name and save the recording to the project folder.